besoin d upgrader la PF de prod en php 5.6+

Aller à : Navigation, rechercher

https://www.facebook.com/groups/gentilsvirus/permalink/2337127896311757/

https://www.facebook.com/groups/GVDEV/permalink/1311007532370298/

Pierro78 (discussion)2 mars 2019 à 15:44

J'ai effectué le passage à PHP 5.6.40 (c'est impossible de passer à PHP 7 tout en gardant la version actuelle de Mediawiki). J'ai procédé ainsi :

  • apt-get upgrade
  • apt-add-repository ppa:ondrej/php
  • apt-get update
  • apt-get install php5.6
  • a2dismod php5
  • a2enmod php5.6
  • apt-get install php5.6-mysqli
  • service apache2 restart

J'ai ensuite mis à jour manuellement le fichier /etc/php/5.6/apache2/php.ini à partir de ce qu'on avait personnalisé dans /etc/php5/apache2/php.ini.

Là-dessus, le wiki a bugué un max, j'ai résolu le souci en patchant /var/www_wiki.gentilsvirus.org/includes/MagicWord.php (cf. lignes ajoutées avec le commentaire « // Group name must start with a non-digit in PCRE 8.34+ »).

Hydronium (discussion)2 mars 2019 à 22:05
 

pb de telechargement de fichier dans le wiki, il a fallu installer php5.6-xml , voir https://www.facebook.com/groups/gentilsvirus/permalink/2337127896311757/?comment_id=2356342364390310

Pierro78 (discussion)16 mars 2019 à 11:18
 

pb php5-gd (sur http://lorraine.gentilsvirus.org/nos-idees/ ) signale par Catherine , il a fallu installer php5.6-gd

Pierro78 (discussion)20 mars 2019 à 22:00
 
Outils personnels

Variantes
Navigation
Lister ou Créer des vidéos / documents / sites web / initiatives / demandes d'aide
Communauté : Réseau social, Mumble, Radio, IRC, Evénements, ...
Groupes ou Pages facebook non locaux - twitter - google+ - Bookmarks sociaux
Groupes locaux - cartes
Boîte à outils
Articles en chantier
Cette plateforme web